Marketron Engineering team was able to fix the issue with the traffic applications launching.
Posted Aug 04, 2026 - 08:03 MDT
Monitoring
Apps are now opening correctly now for most users.
Posted Aug 04, 2026 - 06:31 MDT
Identified
We have Identified the problem and are implementing a fix.
Posted Aug 04, 2026 - 06:27 MDT
Investigating
Users can log in to the mtc.emarketron.com site, but the apps are not launching and some users getting Errors stating terminal server license not available. Our Engineering team is researching the issue.
Posted Aug 04, 2026 - 06:08 MDT
This incident affected: Network Connectivity, Traffic Applications and Traffic Applications (Marketron Traffic Applications, Visual Traffic Application Services).